倒霉,最好不要使用Mac系统默认下的python

最近,用Mac系统开发了一阵以后,一些软件开始崩溃,找了一下原因,原来是我乱升级系统包导致的,我们都知道,OSX系统默认是开发者友好的,python当然必须系统自带的。但是网上又有很多教程,如何在mac系统中安另一个python,原因就是系统自带的python运行运行普通脚本没问题,但是真的开发python项目是有点问题的。系统自带的python可能会版本偏低,这个如果大家都是用最新系统应该都没啥问题了。系统升级的时候,可能会导致已经安装的python包消失。最后也是最重要一点,系统python......

Python在import时遇到的惨案

        最近使用基于python语言的django框架开发web相关的应用,但是在访问页面的时候会不定时的报错,import导入报错 经过近1个月的观察发现有这么几个特性:不知道什么时候会触发,但是一旦触发,就一直存在这个问题只要重启web服务或者调试 问题马上就能解决。   咋一看:难道是django框架不稳定?   不要轻易怀疑框架的问题,绝大多数情况下是自己的问题。 查看一下 __import......

centos安装python2.7

一般centos系统自带的Python是2.6.6版本,由于版本太老有些好用的模块及功能需要Python2.7才支持。简单写一下如何升级Python2.6到Python2.7并能同步使用pip,以及通过pip安装Django。踩过不少坑,总结了下,按下面步骤逐步安装不然会有报错。1、安装openssl openssl-devel如果没安装后面用pip安装软件包的时候可能会提示错误“pip is configured with locations that require TLS/SSL, how......