在mac上配置rails开发环境

  首先,安装home-brew,并且升级到最新的版本,值得一提的是home-brew个人感觉比port要好用,安装软件也方便一点。

  ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)” 
brew update    升级到最新

  做完上面这一步之后,开始设置gem源,需要说明一下的是,淘宝的gem源早在好几年前就没人维护了,但是网上一大堆的攻略都还在推荐淘宝的源,目前唯一靠谱的gem源就是rubychina提供的,推荐使用:gems.ruby-china.org

  通过gem安装最新的rails时,经常会报错误,问题是需要前置安装nokogiri,这里有一个坑,最好指定版本进行安装,才不会报错

  gem install nokogiri -v 1.8.2 -- --use-system-libraries

  安装好nokogiri后,再安装rails

  gem install rails

  安装好后用which rails 寻址

  最后 rails -v 搞定!